Argentina id_details report outage

Incident Report for Emptor

Resolved

Source is back online.
Posted Jul 30, 2025 - 20:12 UTC

Investigating

We've identified an outage for ID validation sources in Argentina. We're currently investigating the issue, and will provide an update soon.
Posted Jul 30, 2025 - 15:23 UTC
This incident affected: Argentina (ID Status).